summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKim Altintop <kim@eagain.io>2023-04-13 16:50:24 +0200
committerKim Altintop <kim@eagain.io>2023-04-13 17:10:18 +0200
commit8ce1155a1eb490625a7e949a10c4283b4b773d30 (patch)
tree4ece9c129b032bed209df94ba520f7a3c940e310 /Cargo.toml
parent607a5609f858cd707dca3a936d80a7a9539b4b5a (diff)
core: replace bundle checksum with BLAKE3
BLAKE3 has a verified streaming mode (Bao), which allows variable chunk sizes without altering the root hash. This means that a BLAKE3 hash can serve as a long-term stable content address in location-independent storage (as demonstrated by iroh). Signed-off-by: Kim Altintop <kim@eagain.io>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4de6fdb..229e85b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,12 +16,15 @@ sha1dc = ["sha1collisiondetection"]
anyhow.features = ["backtrace"]
anyhow.version = "1"
base64.version = "0.13"
+blake3.version = "1.3.3"
+blake3.features = ["traits-preview"]
clap.features = ["derive", "env", "string", "wrap_help"]
clap.version = "4.0"
clap_complete.version = "4.0"
clap_mangen.version = "0.2"
console.default-features = false
console.version = "0.15"
+digest.version = "0.10"
directories.version = "4.0"
either.version = "1.8"
erased-serde.version = "0.3"